[an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive]
 
[an error occurred while processing this directive] [an error occurred while processing this directive]
Skåne Sjælland Linux User Group - http://www.sslug.dk Home   Subscribe   Mail Archive   Forum   Calendar   Search
MhonArc Date: [Date Prev] [Date Index] [Date Next]   Thread: [Date Prev] [Thread Index] [Date Next]   MhonArc
 

Re: [TEKNIK] virtualhosts i Ubuntu



Frank Damgaard skrev:
Leif Lende wrote:
Leif Lende skrev:
Frank Damgaard skrev:
Leif Lende wrote:
Hej
Er der nogen ubuntu/apache folk der måske kan hjælpe?
Er ved at få grå hår.
Jeg kan kun få den første i rækken af NameVirtualHost 192.168.1.3:80
til
at virke. Den bliver vist ved kald af alle virtual hosts.
i Ubuntu og Apache2
Er vandt til redhat baserede systemer, hvor det alltid har virket fint.
Er der et specielt direktiv i Ubuntu, eller er det bare mig der ikke
kan
huske noget der skal slåes til, fra sidste gang? Er ikke helt ung
længere, hehe.
Leif
hvert site har sin egen fil i
 /etc/apache2/sites-available/

og der laves så sym-link til /etc/apache2/sites-enabled/
for hvert site der skal være aktiv.

det var vist i gamle apache1 dage at man lavede det hele
i en stor konfig-fil.
I debian/ubuntu har man længe brugt den ovenfor beskrevne opbygning.

Læs også  /etc/apache2/README
som beskriver opsætningen  i /etc/apache2/


README ligger nu ikke der,  Jeg har installeret dokumentation, men af
en eller anden grund vises det på fransk, som jeg ikke forstår. Jeg må
finde noget på engelsk.
Leif


Fik det ændret til engelsk visning.
Har rodet med opsætningen og minimeret den for at minimere fejl til:

det burde nok være i 2 filer under site-enabled  / sites-available
når det er ubuntu/debian.
Jo, det er meningen, og jeg har lagt det sådan.

NameVirtualHost 192.168.1.5:80

<VirtualHost 192.168.1.5:80>
ServerName test.musikersupport.dk
ServerAlias test. musikerservice.dk

er der et mellemrum for meget efter test. ??
Nej den havde jeg opdaget, men kan se du er vågen

DocumentRoot /var/musikersupport.dk
</VirtualHost>

<VirtualHost 192.168.1.5:80>
ServerName test.natureguide.dk
DocumentRoot /var/natureguide.dk
</VirtualHost>

Nu virker det lokalt.
Men fra Internettet er det afhengigt af at begge adresser videresendes
med ProxyPass / http://192.168.1.5:80/
 på vores public-IP-bærende
webserver apache på Trusrtix linux

Problemet er så åbenbart at navnene test.natureguide.dk og
test.musikersupport.dk osv. ikke kommer med over til
eller fortolkes ikke der, og dermed vises den første i rækken af
virtualhosts (default), da kun IP adressen fortolkes.

Er der en måde at få adressernes <test.*> navne med over og fortolket?

kender ikke lige proxypass , men hvis den fjerner information fra http requests
så må du se i dokumentation til proxypass maskinen.
Apache på du webserver kan i hvertfald ikke trylle det frem igen.
Se evt. i apache log og error filer hvad der kommer frem ved requests.
Kigger på det imorgen. Har sat til log til debug level på begge maskiner.

Leif


 
Home   Subscribe   Mail Archive   Index   Calendar   Search

 
 
Questions about the web-pages to <www_admin>. Last modified 2009-11-01, 02:01 CET [an error occurred while processing this directive]
This page is maintained by [an error occurred while processing this directive]MHonArc [an error occurred while processing this directive] # [an error occurred while processing this directive] *