[an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive] (none) [an error occurred while processing this directive] [an error occurred while processing this directive] [an error occurred while processing this directive][an error occurred while processing this directive]
 
[an error occurred while processing this directive] [an error occurred while processing this directive]
Skåne Sjælland Linux User Group - http://www.sslug.dk Home   Subscribe   Mail Archive   Forum   Calendar   Search
MhonArc Date: [Date Prev] [Date Index] [Date Next]   Thread: [Date Prev] [Thread Index] [Date Next]   MhonArc
 

Re: [TEKNIK] Grub problem - "ødelægger op sætningen"



Anders M wrote:
Ups! Glemte jo filen, som jeg blev gjort opmærksom på :-)

Jeg har bare indsat linierne her i denne besked. Jeg har prøvet at have begge Windows entries slået til. Har også prøvet at have bare den første slået til. Intet hjælper. Jeg har selv lige prøve at rette root til rootnoverify ved Windows, men det hjalp heller ikke. Hvis jeg fjerner alle ##'erne, så virker det fint!

Der ligger desværre både en bootloader (grub) på hda1 og sda1, da jeg lavede en fejl i første installation af Ubuntu.

Hvad er der i vejen her?


default 0 timeout 10

title Linux Ubuntu
root (hd2,0)
kernel /boot/vmlinuz-2.6.20-16-generic root=UUID=cc0aee05-61e1-43ef-b662-407fdd839eeb ro quiet splash
initrd /boot/initrd.img-2.6.20-16-generic
quiet
savedefault


## title        Ubuntu, kernel 2.6.20-16-generic (recovery mode)
## root        (hd2,0)
## kernel        /boot/vmlinuz-2.6.20-16-generic
## root=UUID=cc0aee05-61e1-43ef-b662-407fdd839eeb ro single
## initrd        /boot/initrd.img-2.6.20-16-generic

## title Ubuntu, kernel 2.6.20-15-generic
## root (hd2,0)
## kernel /boot/vmlinuz-2.6.20-15-generic root=UUID=cc0aee05-61e1-43ef-b662-407fdd839eeb ro quiet splash
## initrd /boot/initrd.img-2.6.20-15-generic
## quiet
## savedefault


## title Ubuntu, kernel 2.6.20-15-generic (recovery mode)
## root (hd2,0)
## kernel /boot/vmlinuz-2.6.20-15-generic root=UUID=cc0aee05-61e1-43ef-b662-407fdd839eeb ro single
## initrd /boot/initrd.img-2.6.20-15-generic


## title        Ubuntu, memtest86+
## root        (hd2,0)
## kernel        /boot/memtest86+.bin
## quiet

title        Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS # on /dev/hda1 ## title Windows Vista/Longhorn (loader) ## root (hd0,0) ## savedefault ## chainloader +1


# This entry automatically added by the Debian installer for a non-linux OS # on /dev/sda1 title Windows Vista rootnoverify (hd1,0) savedefault map (hd0) (hd1) map (hd1) (hd0) chainloader +1



Du skriver:
"Hvis jeg fjerner alle ##'erne, så virker det fint!"
Jamen så fjern dem alle (på nær dem ved VISTA, se nedenfor), også dem på den gamle kernel.
Ved afinstallering af den gamle kernel vil referencerne til den blive fjernet.
Og du må under ingen omstændigheder afskære muligheden for at boote i recovery mode.
Memtest må heller ikke fjernes.


Med hensyn til boot af VISTA er grub øjensynligt blevet forvirret fordi hda har været udpeget til boot-device.
Der ville jeg i første omgang bevare ## på grubmenuens reference til hda1=(hd0,0).
men de to map-linier i VISTA-boot fra sda1:
map (hd0) (hd1)
map (hd1) (hd0)
som refererer til hda, ville jeg sætte # på. Hvis det så virker kan de bagefter slettes helt.



-- Med venlig hilsen

Jørgen Heesche
mailto:sslug@sslug


 
Home   Subscribe   Mail Archive   Index   Calendar   Search

 
 
Questions about the web-pages to <www_admin>. Last modified 2007-07-01, 02:02 CEST [an error occurred while processing this directive]
This page is maintained by [an error occurred while processing this directive]MHonArc [an error occurred while processing this directive] # [an error occurred while processing this directive] *